Amazon RDS for PostgreSQL Supports Customer Initiated Snapshot Upgrades

Currently, both System and User Initiated snapshots are based on the engine version used by your Amazon RDS instance. The snapshots are immutable and can only be restored to the same version. This becomes a challenge if you have snapshots for PostgreSQL versions that are already out of support, such as PostgreSQL 9.3 or an older minor version. With this snapshot upgrade feature, you can now upgrade the engine version of user-initiated database snapshots to a higher supported version. 

You can also perform multi major version upgrades of your snapshots which can then be directly restored to the upgraded version, which greatly reduces major version upgrade time.  

Amazon RDS for PostgreSQL makes it easy to set up, operate, and scale PostgreSQL deployments in the cloud. Learn more about upgrading your database instances from the Amazon RDS User Guide. See Amazon RDS for PostgreSQL Pricing for pricing details and regional availability.  



https://aws.amazon.com/about-aws/whats-new/2019/11/amazon-rds-postgresql-supports-customer-initiated-snapshot-upgrades/